(MigrationPermanentException Cannot find a recipient that has mailbox GUID) error when moving mailboxes
Article
Applies to:
Exchange Online
Original KB number: 2956029
Symptoms
Assume that you have a hybrid deployment of on-premises Microsoft Exchange Server and Exchange Online. When you try to offboard or move a mailbox that was created in Exchange Online to the on-premises organization, you receive the following error message:
Error: MigrationPermanentException: Cannot find a recipient that has mailbox GUID '<GUID>'. --> Cannot find a recipient that has mailbox GUID '<GUID>'
Cause
This behavior occurs because the value of the mailbox GUID isn't stamped on the associated mailbox in the on-premises organization.
Note
The mailbox value is stored in the ExchangeGUID property (also known as the msExchMailboxGUID attribute).
This situation occurs because the value of the property isn't synced to the associated remote mailbox in the on-premises organization when a mailbox is created in Exchange Online.
To move a mailbox, the value of the ExchangeGUID property must be the same in the Exchange Online mailbox and in the associated on-premises remote mailbox.
Resolution
Set the ExchangeGUID property on the associated on-premises remote mailbox before you move the mailbox to the on-premises organization. To do this, follow these steps:
Open the Exchange Management Shell on the on-premises server, and then run the following command to check whether the ExchangeGUID property of the on-premises remote mailbox is set:
PowerShell
Get-RemoteMailbox <alias of cloud mailbox to move> | Format-List ExchangeGUID
Note
If the ExchangeGUID property returns all zeros, the value isn't stamped on the on-premises remote mailbox.
Open Windows PowerShell (don't use the Exchange Management Shell), and then connect to Exchange Online. For more info about how to do this, see Connect to Exchange Online PowerShell.
Run the following command to retrieve the value of ExchangeGUID property of the mailbox that you want to move.
To prevent this scenario from occurring, create the mailbox in the on-premises organization, and then move the mailbox to Exchange Online. This stamps the value of the ExchangeGUID property on the mailbox, and then syncs the value to Exchange Online. After you do this, you can return the mailbox to the on-premises organization.
Are you looking to move to the cloud and easily migrate to Business Central online? This module covers how you can use the built-in migration tools to migrate data to Business Central online from specific product versions.
Describes an error message that you receive when you Offboard mailboxes from your on-premises environment to Microsoft 365 in a hybrid deployment. Provides a resolution.
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