Chyba (Přístup byl odepřen) při připojení ke službě Exchange Online pomocí vzdáleného nástroje Windows PowerShell
Článek
Platí pro:
Exchange Online
Problém
Při pokusu o připojení ke službě Microsoft Exchange Online pomocí vzdáleného nástroje Windows PowerShell se zobrazí následující chybová zpráva:
[outlook.office365.com] Connecting to remote server failed with the following error message: Access is
denied. For more information, see the about_Remote_Troubleshooting Help topic.
+ CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [].
PSRemotingTransportException
+ FullyQualifiedErrorId : PSSessionOpenedFailed
Import-PSSession : Cannot validate argument on parameter 'Session'. The argument is null.
Supply a non-null argument and try the command again.
At D:\Users\Connect.ps1:7 char:21
+ Import-PSSession < < < < $Session
+ CategoryInfo : Invalid Data: (:) [Import-PSSession], ParameterBindingValidationException
+ FullyQualifiedErrorId :
ParameterArgumentValidationError,Microsoft.PowerShell.Commands.ImportPSSessionCommand
Příčina
K tomuto problému dochází z jednoho z následujících důvodů:
Zadáváte nesprávné uživatelské jméno nebo heslo.
Pokoušíte se přihlásit ke službě pomocí účtu, který nemá přístup ke službě Exchange Online.
Pokud chcete tento problém vyřešit, přidejte uživatele pomocí Centra pro správu Exchange ve službě Microsoft 365 jako člena skupiny rolí správce. Postupujte takto:
Klikněte na oprávnění a poté klikněte na role správce.
Dvakrát klikněte na skupinu rolí, do které chcete uživatele přidat. Pokud například chcete, aby měl uživatel úplný přístup, který zahrnuje Windows PowerShell, dvakrát klikněte na možnost Správa organizace.
Pokud chcete přidat uživatele do seznamu, klikněte na Přidat ( ) v části Členové.